VHS pack is zoomed in on Essential Graphics Panel. Resolution seems off too

Hello people,

I just bought the VHS pack from the website. It looks like a great tool. I’m having an issue in Premiere Pro though. The selected footage seems to be zoomed in and or has a different resolution. I have a set a custom resolution to my Premiere project of 3840 x 1888. Could that be the issue? In the pictures I uploaded you can see the difference between the Program Panel and the one with the VHS pack in the Essential Graphics Panel.

I hope someone can point me in the right direction… :slight_smile:


Double-check if you have the latest plugin version (Click Account → Check for updates inside the Pack Manager 4). After opening the VHS package inside the plugin, You should import the animation on the timeline. Imported animation will be placed as a placeholder on the full resolution, as the VHS package is auto-resized. You should replace your video/photo instead of placeholder in Essential Graphics → Edit. Also, You should check if you have chose “Scale to fit” in Edit panel (Check attached screenshot). Let us know about your result, please.

1 Like


Thanks for your reply. :pray:

I checked and made sure I have the latest version. I also tried to use the scaling options, but none of those gave me back the full image. I did some testing today and I found out that my project resolution is set as upscaled (twice the size) When I revert it back to it’s original 1920 x 944 everything seems to be working like it should. This is probably the issue.
I did make a little video where you can see the steps I did on the 3840 x 1888 resolution. Maybe you see something that I overlooked, but it looks like I should just stay to the original resolution.

Visit our chat support at aejuice.com, please. We can do a Remote Control Session to check it on your side.

1 Like

Thank you for the reply.

I will be contacting the support chat soon.

I’ve just tried to reproduce the issue on Windows with no luck.
Did you try these buttons? You can set custom width and height, X and Y positions. Click on the chain if you need them to not be proportionate.

Just to make sure I understand the problem… Is the problem that the video upscaled compared to the original or is it a rectangle gap here?

P.S. I’ve asked my colleague with mac to try to reproduce the issue in the meantime.