AE Juice Gif file too big

Hi, i donwnloaded the free pluging to make gif
i’ve been able to convert a 20 sec video into a gif that was 28mo
i had the redo the gif after correcting my video, now the gif 365 mo!
i don’t understand i didn’t change any settings. it the same MP4 video, why can’t i get the same small files, it’s insane i don’t understand…

Hello, is this problem occurring only with a specific video file? Have you checked whether the problem persists in the new project?
Could you provide us with more information, please? To do so, send a report from the plugin. Click Account → Report a problem. Here is the instruction

It will help to fix the problem faster

well i just wanted to make a gif out of a 2.7 mo video. 20 sec length
the first time a exported it i got a file of 28mo now it’s more than 250 and i haven’t changed the settings, so i don’t get it…
i dont know what other test to do, or what more info to give…i reinstalled the pluggin but i didn’t do anything.
i’m on a Mac M2 ventura and AE 2022
how do i make a clean uninstall?


Please try to open Pack Manager and press Shift+D on your keyboard. Once the scripts are downloaded. Check the work of Export Gif.

We also have an article about how to uninstall Pack Manager.

But first please try to use Shift+D and check the size of the gif.

Please let us know the result.
Also please send us a report if that didn’t work. Click Account → Report a problem. Here is the instruction

I reinstall everything and it’s still making me big file
I don’t know how it was able to make a small one the first time…

Could you please specify the resolution of your video?
Because at high resolution, with 20 seconds duration and fps saving, the gif size can be large with minimal quality loss. Please try to decrease the fps of your exported video in Settings AEJuice Export GIF, you can also make the resolution of your composite smaller.
You can send us a report so that our team can check it. After exporting the gif, Click Account → Report a problem. Here is the instruction

resolution is 1920 x 1080 fps 25
I know it’s big, but what’s strange is that i’ve been able to get a 28mo file once, and i don’t understand how it worked then a now no more…
it would be nice to be able to have more settings when exporting, like the quality…high, medium, low… and maybe use a mp4 compression instead of a ProRes? when exporting it’s written .mov i’m assuming it’s making a ProRes before making the gif and maybe that’s why the files is big…
i’m sure you could improve the compressing codecs

After starting export to GIF, the video file is first rendered to .mov then converted to .gif
We have passed your suggestion for improving AEJuice Export GIF to our team. Thank you!
With these settings, the size of the resulting gif is quite possible. You can do less FPS to reduce the file size.
Also, the first 28mb gif you exported had exactly the same settings? Please check, maybe this file has less length or worse quality.

Please attach a file and a screenshot with your settings. I’ll take a look.

We have also added five new parameters in Export GIF that affect the file size. Please open Pack Manager and press on your keyboard Shift+D, after loading scripts open Export GIF and go to settings.

I think i had the original settings when i’ve done my export, and it exported the entire video.
if i lower the fps it won’t be as smooth as the orginal video…
And now after updating the plugging i have this error message
file: /Applications/Adobe%20After%20Effects%202022/Scripts/ScriptUI%20Panels/AEJuice%20Export%20GIF.jsxbin line: 7023 error: Object of type File found where a Number, Array, or Property is needed stack:onClick()

file: /Applications/Adobe%20After%20Effects%202022/Scripts/ScriptUI%20Panels/AEJuice%20Export%20GIF.jsxbin line: 7023 error: Object of type File found where a Number, Array, or Property is needed stack:onClick()

I have sent a report for that error


Thanks for your report

We have reviewed your report and responded to your email.

Please let us know if our solution worked.

Ha! i don’t have the error message and now my export made me a 25mo file
BUT what’s strange is that this process work when i imported my video to an existing project
if i create a new project and import my video and do the export i have a 365 mo file!?
i don’t understand this weird thing
there are a lot of weird stuff, everytime i restart or open for the first time AE
this is the setting i have for exportGIF
if i want the full setting i have to do shift + D everytime… :crazy_face:

There should be no difference as the script works the same way every time. It renders whatever you have on the timeline in either AVI or MOV, then it converts the video to GIF.

You could try to render out the video file and project using our preset AEJuice MOV (or note which one is used to render on your platform) and compare the files. If the file sizes are different I don’t think we can do anything. It is how After Effects exports.

I was thinking to add “Best Settings”, “Draft Settings” controls to settings if it will help to fix the issue.

Shift+D is a temporary way to access “experimental” features that are not yet available to the public.

Once we release the next update (usually every 2 weeks) these features will be available at all times.

Ok thanks for the info on why i have to redo the update of the script
I didn’t find the AEJuice MOV preset…
but i have made few other test and everytime i make an export from a new project it make me a big file…
once it did not, but i don’t know how…it’s very very weird…it’s like the script works better with a background project, maybe for the cache?
i think it’s agood idea to add “Best Settings”, “Draft Settings” (also medium) for other situations when you really need very small files, that would give more options to people

Some good news.

I’ve added Render Settings and Output Module. Now you can create your own custom template (MP4, AVI, or MOV) with any settings and use it instead of the default one.

This alone will allow you to control the quality, and size of the file in a more flexible way.

Additionally, if you select a footage instead of composition in the project window the script will now ask you if you want to rerender the footage (applying resize, fps, etc. settings) or convert existing video as is.

If you skip rendering the script will go straight to converting to GIF. Hopefully, it will resolve the issue of bloating the size.

Press Shift+D to load the newer version.

Let me know if it works.

Hi, thanks for the update, it seems to work now

but only if i select the video files from the left column

if i render from a comp it’s still a big file strangely…

i also have this error message at the end of the render, but it didn’t avoid making the gif

file: /Applications/Adobe%20After%20Effects%202022/Scripts/ScriptUI%20Panels/AEJuice%20Export%20GIF.jsxbin line: 10330 error: null is not an object stack:onClick()

anonymous(" Processing…")

anonymous([Object:[object Object]])

anonymous([Error:TypeError: null is not an object],false)

Without your project file, I cannot reproduce the issue of the big file. You can send it at

As for the error, please press Account-Report problem and let me know the issue ID. I’ll take a look.

sorry haven’t had the time to sent the report
i sent you the files with wetransfer

I got 1 mp4 file which gives me nothing since the issue is not with the file.

Without the report and project file’s sources, I cannot help.